Fun times with Apache 2.4.3, PHP 5.4.3, and MySql 5.5 updates

About a month ago I got a virus on my computer and in my infinite wisdom I used a registry scanner to help clean up the issue.  This scanner also decided to delete some files that allowed my website to work.   I should have just rolled back my windows 7 to the last registry backup, but too late the damage was done.  For the life of me I couldn’t figure out which files it wiped out as it didnt’ have a log of the actions it took.

So I embarked on re-setting up my apache server.  I didn’t keep any of the installation files I used the first go around so I ended up downloading the files all over again. I got apache from Apache Lounge.  I found 64-bit version of php at http://www.anindya.com/php-5-4-3-and-php-5-3-13-x64-64-bit-for-windows/  and don’t forget about the extensions needed on the same webpage.  And MySQL from their own website. Lesson 1:  Save the installation files for future re-use.

Well of course apache, php, and mysql all had updates that caused various issues.  This being my first real upgrade I discovered something quite important that is noted in all the installation files.  First backup the apache and php config files.  Then start with the generic config files (httpd.conf and php.ini-production) and then add back in my unique settings.  I initially tried to just start with my old configuration files and then add in the new default settings, but this is really messy and not the way to do it.

In apache, Order commands are depreciated are now depreciated  as noted in these two links (1 and 2) so I had to make several updates to the httpd.conf file to correct this.  Additionally, several changes were made to the LoadModule selections.

 #new for 2.4.3 update
LoadModule access_compat_module modules/mod_access_compat.so
LoadModule allowmethods_module modules/mod_allowmethods.so
###This is needed for SSL to work in update
LoadModule socache_shmcb_module modules/mod_socache_shmcb.so
#changed with 2.4.3 update
#LoadModule authz_default_module modules/mod_authz_default.so
LoadModule authz_core_module modules/mod_authz_core.so
#changed with 2.4.3 update
#LoadModule authn_default_module modules/mod_authn_default.so
LoadModule authn_core_module modules/mod_authn_core.so

With the updates I was/am having issues with wordpress so I updated that again too to version 3.4.2 and still noticed the problem with numeric links and have blogged about it here.

But after all of that I appear to be back up and working.  I did notice during this whole process that the use of Location in the httpf.conf file to make sure certain webpages use https rather than http was not case sensitive.  I’m still working on this and hope to post about it again when I understand things, but for here is a link the my forum post about the topic

Tags: , , , , , ,

  1. ryan’s avatar

    If you’re on Windows, why not run wamp? I use it every time I need this stack on Windows and it works well.

    Reply

    1. Brian Thompson’s avatar

      I wanted to better understand setting up a full website and didn’t want to take any shortcuts. Also, I found that there is better support online for the individual apps rather than the combined Wamp when issues arose though I cannot remember what my issues were now.

      Reply

Leave a Reply